Как найти реквизиты дела, указанного ниже?
Expertrating.ru

Юридический портал

Как найти реквизиты дела, указанного ниже?

Как найти реквизиты дела, указанного ниже?

Об актуальных изменениях в КС узнаете, став участником программы, разработанной совместно с ЗАО “Сбербанк-АСТ”. Слушателям, успешно освоившим программу выдаются удостоверения установленного образца.

Лекторы – ведущие эксперты, непосредственные разработчики законов:
В. В. Витрянский, Л. Ю. Михеева, Е. А. Суханов, А. А. Маковская. Принять участие можно очно/ онлайн или в записи, в любой точке страны!

Недавно гражданское дело рассмотрели без участия организации, так как организация сменила юридический адрес, а судья об этом не знала, направила уведомление по старому адресу.
Должен ли судья районного суда в случае обращения гражданина с иском к юридическому лицу заказывать выписку из ЕГРЮЛ в отношении этого юридического лица, чтобы удостовериться в правильности указанных в иске реквизитов юридического лица?

Прежде всего отметим, что ни гражданское законодательство, ни гражданско-процессуальное законодательство не содержат понятия “реквизиты юридического лица”. Между тем оно довольно широко используется на практике. При этом под “реквизитами юридического лица” понимаются сведения, позволяющие идентифицировать данное юридическое лицо. К таким сведениям, в частности, относятся наименование и место нахождения юридического лица, его основной государственный регистрационный номер (ОГРН) в Едином государственном реестре юридических лиц (ЕГРЮЛ), а также идентификационный номер налогоплательщика (ИНН).
Наименование и место нахождения юридического лица определяются его учредителями (участниками) в уставе и регистрируются в ЕГРЮЛ (ст. 51, п.п. 1, 2 ст. 54 ГК РФ, пп.пп. “а”, “в” п. 1 ст. 5 Федерального закона от 8 августа 2001 г. N 129-ФЗ “О государственной регистрации юридических лиц и индивидуальных предпринимателей” (далее – Закон N 129-ФЗ))*(1).
ОГРН и ИНН присваивают налоговые органы при регистрации сведений в ЕГРЮЛ и постановке на налоговый учет соответственно (п. 2 ст. 4 Закона N 129-ФЗ, ст. 84 НК РФ, Порядок и условия присвоения, применения, а также изменения идентификационного номера налогоплательщика при постановке на учет, снятии с учета юридических и физических лиц, утвержденный приказом МНС РФ от 3 марта 2004 г. N БГ-3-09/178).
Содержащиеся в ЕГРЮЛ сведения и документы являются открытыми и общедоступными, за исключением сведений, доступ к которым ограничен законом, и предоставляются, в частности, в виде выписки из соответствующего государственного реестра (пункты 1, 2 ст. 6 Закона N 129-ФЗ).
По общему правилу (ч. 1 ст. 4 ГПК РФ) поводом к возбуждению гражданского дела является заявление лица, обратившегося в суд за защитой своих прав, свобод и законных интересов. Требования к форме и содержанию заявления, состав прилагаемых к заявлению документов, оговорены в статьях 131, 132 ГПК РФ. При этом если ответчиком является организация, в заявлении указывается ее наименование и место нахождения. Кроме того, в заявлении могут содержаться номера телефонов, факсов, адреса электронной почты этой организации. Перечисленные сведения необходимы судье для надлежащего извещения организации-ответчика о времени и месте рассмотрения дела, для направления предложения о представлении имеющихся доказательств по делу, а также для предупреждения о последствиях непредставления этих доказательств и неявки в суд (ч. 5 ст. 113, ч. 2 ст. 114, ч. 2 ст. 150 ГПК РФ).
Вместе с тем, подготавливая дело к разбирательству, суд, исходя из положений ст. 148, п. 14 ч. 1 ст. 150 ГПК РФ, вправе истребовать у организации, участвующей в деле в качестве ответчика, правоустанавливающие документы с реквизитами либо запросить в органе Федеральной налоговой службы по месту нахождения этой организации выписку из ЕГРЮЛ со сведениями о ее наименовании, месте нахождения и иными сведениями, необходимыми для своевременного и правильного разрешения дела (смотрите, например, апелляционное определение СК по гражданским делам Свердловского областного суда от 6 ноября 2014 г. по делу N 33-14088/2014, апелляционное определение СК по гражданским делам Санкт-Петербургского городского суда от 26 июня 2014 г. по делу N 33-8319/14, апелляционное определение СК по гражданским делам Свердловского областного суда от 30 октября 2014 г. по делу N 33-13950/2014).
Получение достоверных сведений об ответчике позволит исключить возможное неправильное уведомление ответчика о дате и времени судебного разбирательства, внесение неправильного наименования ответчика в исполнительный лист и, как следствие, отмену судебных актов или затягивание исполнительного производства по этим причинам.
Заметим, что в отличие от пункта 9 ч. 1 ст. 126 АПК РФ, устанавливающего в качестве обязательного приложения к исковому заявлению выписки из ЕГРЮЛ с указанием сведений об организации-ответчике, ст. 132 ГПК РФ не предусматривает такой выписки в качестве обязательного документа, прилагаемого к исковому заявлению. Как уже указывалось выше, в гражданском процессе выписка из ЕГРЮЛ, содержащая сведения об организации-ответчике, может быть запрошена по инициативе суда. Кроме того, поскольку содержащиеся в ЕГРЮЛ сведения и документы являются открытыми и общедоступными, выписка из ЕГРЮЛ может быть истребована самим истцом и приложена к исковому заявлению либо по его ходатайству приобщена к материалам дела (смотрите, например, апелляционное определение СК по гражданским делам Московского областного суда от 14 марта 2013 г. по делу N 33-6261/1, определение СК по гражданским делам Московского городского суда от 14 ноября 2011 г. N 33-36443, постановление Президиума Санкт-Петербургского городского суда от 17 января 2007 г. N 44г-22/07).

Ответ подготовил:
Эксперт службы Правового консалтинга ГАРАНТ
Глебов Валерий

Контроль качества ответа:
Рецензент службы Правового консалтинга ГАРАНТ
Амирова Лариса

————————————————————————-
*(1) В соответствии с п. 1 ст. 25 Закона N 129-ФЗ за непредставление или несвоевременное представление сведений, необходимых для включения в государственные реестры, заявитель и юридические лица несут ответственность, установленную законодательством РФ. На основании п. 3 ст. 14.25 КоАП РФ непредставление или несвоевременное представление или представление недостоверных сведений о юридическом лице или об индивидуальном предпринимателе в орган, осуществляющий государственную регистрацию юридических лиц и индивидуальных предпринимателей, в случаях, если такое представление предусмотрено законом, влечет предупреждение или наложение административного штрафа на должностных лиц в размере пяти тысяч рублей.
Заметим также, что юридическое лицо несет риск последствий неполучения юридически значимых сообщений (ст. 165.1 ГК РФ), доставленных по адресу, указанному в ЕГРЮЛ, а также риск отсутствия по указанному адресу своего органа или представителя. Сообщения, доставленные по адресу, указанному в ЕГРЮЛ, считаются полученными юридическим лицом, даже если оно не находится по указанному адресу (п. 3 ст. 54 ГК РФ).

Ответы на вопросы

Поделиться в социальных сетях

Реквизиты банковского счета взыскателя Отправить по электронной почте

Бюджетным кодексом Российской Федерации определено, что к исполнительному листу, направленному на исполнение должны быть приложены реквизиты банковского счета взыскателя* на который должны быть перечислены средства, подлежащие взысканию.

Выплата взыскателю сумм по исполнительному листу наличными денежными средствами либо почтовым переводом, а также выплаты денежных средств лицам, не являющимся взыскателям по судебному акту бюджетным законодательством не предусмотрена.

В случае, если взыскателем либо судом, направившим исполнительный лист на исполнение, не представлены реквизиты банковского счета взыскателя, Министерство финансов Российской Федерации лишено возможности исполнить судебный акт.
Если номер лицевого счета указан взыскателем (судом) неверно, содержит большее или меньшее количество знаков (номер лицевого счета должен содержать 20 знаков), либо вместо номера лицевого счета указан только номер пластиковой банковской карты, Министерство финансов Российской Федерации не имеет возможности сформировать платежные документы и исполнить решение суда (Пример 1).

Читать еще:  Погас фитиль в газовой колонке что делать

Кроме того, не представляется возможным перечислить денежные средства на банковский счет взыскателя, в случае если по условиям договора, заключенного между банком и взыскателем, пополнение банковского счета запрещено.
Если взыскатель не имеет возможности лично обратиться в банк для открытия лицевого счета, взыскатель вправе выдать доверенность своему представителю на открытие и распоряжение своим банковским счетом.
Осужденным, отбывающим наказание в исправительных учреждениях ФСИН России, бухгалтерией учреждения открываются лицевые счета.

Таким образом, взыскатели вправе вместо реквизитов банковского счета взыскателя физического лица представить в Министерство финансов Российской Федерации реквизиты счета учреждения ФСИН России, в котором взыскатель отбывает наказание, для последующего зачисления денежных средств на лицевой счет взыскателя (Пример 4).

Взыскатели, постоянно проживающие за пределами Российской Федерации не имеющие возможности открыть счет в банке на территории Российской Федерации для исполнения судебного акта могут представить реквизиты банковского счета, открытого в иностранном банке в валюте Российской Федерации (Пример 2).

В случае невозможности перечисления денежных средств по реквизитам банковского счета, указанного взыскателем и (или) судом в исполнительном документе, Министерство финансов Российской Федерации направляет в адрес взыскателя и (или) суда, уведомление об уточнении реквизитов банковского счета взыскателя.

Если уточненные реквизиты банковского счета взыскателя не представлены в Министерство финансов Российской Федерации в течение 30 дней со дня направления взыскателю или в суд уведомления об уточнении реквизитов банковского счета взыскателя, исполнительный документ возвращается взыскателю без исполнения (пункт 3.2 статьи 242.1 Бюджетного кодекса Российской Федерации).

* Примеры написания реквизитов банковского счета взыскателя:

1. Пример написания реквизитов банковского счета взыскателя – физического лица:
Наименование банка получателя: Центрально-Черноземный Банк СБ РФ
БИК Банка: 042007681 (9 знаков)
Корреспондентский счет Банка: 30101810600000000681 (20 знаков)
Отделение СБ РФ № 9013*
ИНН Банка: 7707083893
КПП Банка: 615250001
Расчетный счет Банка: 30301810855000605513 (20 знаков)
Взыскатель: Иванов Иван Иванович
Лицевой счет взыскателя: 42307810255133401027 (20 знаков)
*Если лицевой счет взыскателя открыт в филиале ОСБ РФ, необходимо также указать номер филиала.

2. Пример написания реквизитов банковского счета взыскателя – физического лица, открытого в валюте Российской Федерации, постоянно проживающего за пределами Российской Федерации и не имеющего возможности открыть счет в банке на территории Российской Федерации:
Наименование Банка получателя, находящегося на территории Российской Федерации : ООО «Промсвязьбанк» г. Москва
БИК Банка: 044583119 (9 знаков)
Корреспондентский счет Банка: 30101810600000000119 (20 знаков)
Получатель: АО «Bank RBK»
Расчетный счет Банка: 30111810800000522201 (20 знаков)
Взыскатель: Иванов Иван Иванович
Расчетный счет взыскателя, открытый в валюте Российской Федерации: _______________________.

3. Пример написания реквизитов банковского счета взыскателя –юридического лица, счет которому открыт в Банке:
Наименование организации взыскателя
ИНН организации взыскателя
КПП организации взыскателя
Расчетный счет организации (взыскателя)
Наименование Банк получателя (взыскателя)
БИК Банка
Корреспондентский счет Банка
Отделение банка или доп. офис коммерческого банка (получатель)
Расчетный счет отделения Банка или доп. офиса коммерческого банка

4. Пример написания реквизитов банковского счета взыскателя – юридического лица (учреждения ФСИН России в котором взыскатель физическое лицо содержится/отбывает наказание), счет которому открыт в органах федерального казначейства (УФК)*:
Наименование организации взыскателя / учреждения ФСИН России
ИНН организации взыскателя / учреждения ФСИН России
КПП организации взыскателя / учреждения ФСИН России
Расчетный счет организации взыскателя/ учреждения ФСИН России
УФК в котором открыт лицевой счет взыскателя / учреждения ФСИН России
Лицевой счет организации взыскателя/учреждения ФСИН России, открытый в УФК
БИК Банка
Корреспондентский счет Банка
ОКТМО
КБК

* Если взыскатель физическое лицо направляет в Министерство финансов Российской Федерации реквизиты учреждения ФСИН России, в котором взыскатель содержится/отбывает наказание, указывается номер расчетного (депозитного) счета учреждения для учета личных денежных средств осужденных. При этом ОКТМО и КБК не указываются.

Как найти реквизиты дела, указанного ниже?

Об актуальных изменениях в КС узнаете, став участником программы, разработанной совместно с ЗАО “Сбербанк-АСТ”. Слушателям, успешно освоившим программу выдаются удостоверения установленного образца.

Лекторы – ведущие эксперты, непосредственные разработчики законов:
В. В. Витрянский, Л. Ю. Михеева, Е. А. Суханов, А. А. Маковская. Принять участие можно очно/ онлайн или в записи, в любой точке страны!

Недавно гражданское дело рассмотрели без участия организации, так как организация сменила юридический адрес, а судья об этом не знала, направила уведомление по старому адресу.
Должен ли судья районного суда в случае обращения гражданина с иском к юридическому лицу заказывать выписку из ЕГРЮЛ в отношении этого юридического лица, чтобы удостовериться в правильности указанных в иске реквизитов юридического лица?

Прежде всего отметим, что ни гражданское законодательство, ни гражданско-процессуальное законодательство не содержат понятия “реквизиты юридического лица”. Между тем оно довольно широко используется на практике. При этом под “реквизитами юридического лица” понимаются сведения, позволяющие идентифицировать данное юридическое лицо. К таким сведениям, в частности, относятся наименование и место нахождения юридического лица, его основной государственный регистрационный номер (ОГРН) в Едином государственном реестре юридических лиц (ЕГРЮЛ), а также идентификационный номер налогоплательщика (ИНН).
Наименование и место нахождения юридического лица определяются его учредителями (участниками) в уставе и регистрируются в ЕГРЮЛ (ст. 51, п.п. 1, 2 ст. 54 ГК РФ, пп.пп. “а”, “в” п. 1 ст. 5 Федерального закона от 8 августа 2001 г. N 129-ФЗ “О государственной регистрации юридических лиц и индивидуальных предпринимателей” (далее – Закон N 129-ФЗ))*(1).
ОГРН и ИНН присваивают налоговые органы при регистрации сведений в ЕГРЮЛ и постановке на налоговый учет соответственно (п. 2 ст. 4 Закона N 129-ФЗ, ст. 84 НК РФ, Порядок и условия присвоения, применения, а также изменения идентификационного номера налогоплательщика при постановке на учет, снятии с учета юридических и физических лиц, утвержденный приказом МНС РФ от 3 марта 2004 г. N БГ-3-09/178).
Содержащиеся в ЕГРЮЛ сведения и документы являются открытыми и общедоступными, за исключением сведений, доступ к которым ограничен законом, и предоставляются, в частности, в виде выписки из соответствующего государственного реестра (пункты 1, 2 ст. 6 Закона N 129-ФЗ).
По общему правилу (ч. 1 ст. 4 ГПК РФ) поводом к возбуждению гражданского дела является заявление лица, обратившегося в суд за защитой своих прав, свобод и законных интересов. Требования к форме и содержанию заявления, состав прилагаемых к заявлению документов, оговорены в статьях 131, 132 ГПК РФ. При этом если ответчиком является организация, в заявлении указывается ее наименование и место нахождения. Кроме того, в заявлении могут содержаться номера телефонов, факсов, адреса электронной почты этой организации. Перечисленные сведения необходимы судье для надлежащего извещения организации-ответчика о времени и месте рассмотрения дела, для направления предложения о представлении имеющихся доказательств по делу, а также для предупреждения о последствиях непредставления этих доказательств и неявки в суд (ч. 5 ст. 113, ч. 2 ст. 114, ч. 2 ст. 150 ГПК РФ).
Вместе с тем, подготавливая дело к разбирательству, суд, исходя из положений ст. 148, п. 14 ч. 1 ст. 150 ГПК РФ, вправе истребовать у организации, участвующей в деле в качестве ответчика, правоустанавливающие документы с реквизитами либо запросить в органе Федеральной налоговой службы по месту нахождения этой организации выписку из ЕГРЮЛ со сведениями о ее наименовании, месте нахождения и иными сведениями, необходимыми для своевременного и правильного разрешения дела (смотрите, например, апелляционное определение СК по гражданским делам Свердловского областного суда от 6 ноября 2014 г. по делу N 33-14088/2014, апелляционное определение СК по гражданским делам Санкт-Петербургского городского суда от 26 июня 2014 г. по делу N 33-8319/14, апелляционное определение СК по гражданским делам Свердловского областного суда от 30 октября 2014 г. по делу N 33-13950/2014).
Получение достоверных сведений об ответчике позволит исключить возможное неправильное уведомление ответчика о дате и времени судебного разбирательства, внесение неправильного наименования ответчика в исполнительный лист и, как следствие, отмену судебных актов или затягивание исполнительного производства по этим причинам.
Заметим, что в отличие от пункта 9 ч. 1 ст. 126 АПК РФ, устанавливающего в качестве обязательного приложения к исковому заявлению выписки из ЕГРЮЛ с указанием сведений об организации-ответчике, ст. 132 ГПК РФ не предусматривает такой выписки в качестве обязательного документа, прилагаемого к исковому заявлению. Как уже указывалось выше, в гражданском процессе выписка из ЕГРЮЛ, содержащая сведения об организации-ответчике, может быть запрошена по инициативе суда. Кроме того, поскольку содержащиеся в ЕГРЮЛ сведения и документы являются открытыми и общедоступными, выписка из ЕГРЮЛ может быть истребована самим истцом и приложена к исковому заявлению либо по его ходатайству приобщена к материалам дела (смотрите, например, апелляционное определение СК по гражданским делам Московского областного суда от 14 марта 2013 г. по делу N 33-6261/1, определение СК по гражданским делам Московского городского суда от 14 ноября 2011 г. N 33-36443, постановление Президиума Санкт-Петербургского городского суда от 17 января 2007 г. N 44г-22/07).

Читать еще:  Зачем нужен паспорт в 14 лет

Ответ подготовил:
Эксперт службы Правового консалтинга ГАРАНТ
Глебов Валерий

Контроль качества ответа:
Рецензент службы Правового консалтинга ГАРАНТ
Амирова Лариса

————————————————————————-
*(1) В соответствии с п. 1 ст. 25 Закона N 129-ФЗ за непредставление или несвоевременное представление сведений, необходимых для включения в государственные реестры, заявитель и юридические лица несут ответственность, установленную законодательством РФ. На основании п. 3 ст. 14.25 КоАП РФ непредставление или несвоевременное представление или представление недостоверных сведений о юридическом лице или об индивидуальном предпринимателе в орган, осуществляющий государственную регистрацию юридических лиц и индивидуальных предпринимателей, в случаях, если такое представление предусмотрено законом, влечет предупреждение или наложение административного штрафа на должностных лиц в размере пяти тысяч рублей.
Заметим также, что юридическое лицо несет риск последствий неполучения юридически значимых сообщений (ст. 165.1 ГК РФ), доставленных по адресу, указанному в ЕГРЮЛ, а также риск отсутствия по указанному адресу своего органа или представителя. Сообщения, доставленные по адресу, указанному в ЕГРЮЛ, считаются полученными юридическим лицом, даже если оно не находится по указанному адресу (п. 3 ст. 54 ГК РФ).

Реквизиты предприятия: сведения, которые должны быть у каждого

Полный перечень сведений о юридическом лице

Обязательная открытая информация о юридическом лице, которая может использоваться органами власти, контрагентам, партнерами по бизнесу и самими предприятиями для оформления соответствующих документов, включает следующие данные:

  • полное и сокращенное наименование;
  • юридический адрес — адрес, по которому зарегистрирована компания. Может не совпадать с местом, где фактически осуществляется деятельность. Туда обязательно должны входить почтовый индекс, наименование местности, улица (ул.) и номер строения;
  • контактная информация — номер телефона, факса, e-mail;
  • основной государственный регистрационный номер (ОГРН). Присваивается при регистрации записи о создании юридического лица в единый реестр юрлиц, состоит из 13 символов;
  • идентификационный номер налогоплательщика (ИНН). Выдается ИФНС, если получатель — юридическое лицо, то содержит 10 символов;
  • код причины постановки на учет в ИФНС (КПП). Присваивается только организациям вместе с ИНН, состоит из 9 знаков;
  • код из Общероссийского классификатор предприятий и организаций (код ОКПО). Получают в территориальном подразделении Росстата, код помогает определить сферу деятельности организации;
  • код по Общероссийскому классификатору видов экономической деятельности (по ОКВЭД). Подбирается по классификатору компанией самостоятельно, можно выбрать несколько кодов;
  • сведения о расчетном счете, корреспондентском счете банка, где он открыт, БИК этого банка. Информацию выдает обслуживающая банковская организация при подписании договора с компанией. Информацию раскрывать надо не всегда, например, в трудовых договорах ее можно опустить, а в договорах на поставку товаров клиентам без нее никак не обойтись.

Дополнительно контрагентам и органам власти могут понадобиться и другие реквизиты юридического лица. Например, страховщики и банки обязательно информируют о выданной лицензии. Некоторые работодатели сообщают заинтересованным лицам регистрационный номер в ПФР. Компании также по собственному усмотрению, а иногда и в обязательном порядке, если это предусмотрено законодательством, представляют коды по ОКАТО (Общероссийскому классификатору объектов административно-территориального деления), ОКОГУ (Общероссийскому классификатору органов госвласти и управления), ОКОПФ (Общероссийскому классификатору организационно-правовых форм), ОКФС (Общероссийскому классификатору форм собственности). В некоторых случаях еще указывают ФИО руководителя и бухгалтера организации.

Образец реквизитов

Полное наименование организации Общество с ограниченной ответственностью «Весна»
ЮРИДИЧЕСКИЙ АДРЕС 123456, г. Москва, ул. Подвойского, д. 14, стр. 7
Почтовый адрес 123456, г. Москва, ул. Подвойского, д. 14, стр. 7
ИНН 7712345678
КПП 779101001
БИК 044521234
Р/С 40702810123450101230 в Московский банк ПАО Сбербанк г. Москва
К/С 30101234500000000225
ОКПО 12345678
ОКАТО 87654321000
ОКВЭД (основной) 18.15
ОГРН 1047712345678
Генеральный директор Петров Сергей Петрович
Электронная почта info@vesna.ru
Телефон +749512345678
Сайт www.vesna.ru

Где найти и как передать реквизиты юр лица

Для того чтобы найти реквизиты, нужно знать как минимум наименование или ИНН организации (например ИП — индивидуального предпринимателя или ООО — общества с ограниченной ответственностью). Все сведения о контрагенте можно найти в выписке из ЕГРЮЛ. Такая услуга доступна на сайте Налоговой службы России и в иных, в том числе платных, сервисах.

В то же время компании заботятся о том, чтобы вся информация о них была общедоступной. Поэтому почти всегда размещают реквизиты на официальных страницах в интернете — в разделе «О компании».

Посмотрим образец реквизитов организации на примере ПАО Сбербанк. Картинка ниже — официально опубликованная на сайте кредитной организации информация.

В сокращенном варианте Сбербанк показывает свои реквизиты вот так:

Правила размещения в бланках документов

Всю необходимую информацию организации всегда указывают в договорах и на бланках. Согласно ГОСТ, реквизиты могут размещаться в двух вариантах: в левом углу либо по центру листа. Поэтому образец бланка организации с реквизитами может выглядеть по-разному.

Читать еще:  Как аннулировать лицензию такси через госуслуги

Вариант 1. Реквизиты предприятия размещены слева.

Вариант 2. Размещение реквизитов по центру.

Какой из этих шаблонов будет использоваться, решает сама компания. Главное, чтобы реквизиты были хорошо видны и в них не было ошибок. Также обращаем внимание, что разрешается дублировать реквизиты на русском и английском (другом иностранном) языках.

Универсальные функции получения значений реквизитов объектов (8.2+)

Общий принцип оптимизации заключается в сокрашении количества обращений к базе данных. Для этого в линейном алгоритме анализируем, что за объект перед нами, если это ссылка, то описываем запрос, с помощью которого получаем все данные и в дальнейшем работаем с результатом запроса.

Задача: Описать функции позволяющие получить значения реквизитов различных объектов (независимо от типа объекта). Но ограничимся объектами метаданных конфигурации, которые могут иметь ссылочный тип данных: Справочники, Документы и т.п.

Описанные далее функции желательно располагать в общем серверном модуле без возможности вызова сервера. Если будет возможность вызывать данные функции с клиента, то злоумышленник сможет получить любые данные из базы без особого труда.

Определимся с параметрами:

  1. Объект – объект, данные которого необходимо получить;
  2. ИменаРеквизитов – Список имен реквизитов, данные которых необходимо получить. Если спиок не указан, то предполагаем, что нужно получить данные всех реквизитов;
  3. ДополнительныеРеквизиты – Структура, с помошью которой можно было бы описать дополнительные данные, которые нужно получить вместе с реквизитами объекта (без использования явных соединений с другими таблицами) или выполнение каких-то действий с полями выборки на языке запросов. В ключе элемента структуры описываем имя реквизита в общем списке реквизитов объекта, в значении – поле выборки или алгоритм обработки полей выборки на языке запросов.

Функция ДанныеРеквизитовОбъекта ( Объект , ИменаРеквизитов = Неопределено,
ДополнительныеРеквизиты = Неопределено) Экспорт

Разберем, значения каких реквизитов необходимо получить из базы и приведем список имен к типу данных Массив.

СтруктураОбъекта = Новый Структура ;
МетаданныеОбъекта = Объект . Метаданные ();

Если ИменаРеквизитов = Неопределено тогда
МассивИменРеквизитов = МассивИменРеквизитовОбъекта ( Объект );
иначе
Если ТипЗнч ( ИменаРеквизитов ) = Тип ( “Массив” ) тогда
МассивИменРеквизитов = ИменаРеквизитов ;
иначеЕсли ТипЗнч ( ИменаРеквизитов ) = Тип ( “Строка” ) тогда
МассивИменРеквизитов = МассивПодстрокИзСтроки ( ИменаРеквизитов );
КонецЕсли;
КонецЕсли;

Если список имен не задан, то с помощью функции МассивИменРеквизитовОбъекта () получим массив имен всех реквизитов объекта (алгоритм этой функции смотри ниже).

Если список имен задан в виде строки разделенной запятыми, то разложим ее на подстроки с помошью функции МассивПодстрокИзСтроки () . Это не сложная задача, алгоритм этой функции разбирать не будем.

Далее с помошью функции ЭтоСсылка () определим, является ли объект ссылочным типом. Для ссылочных типов значения необходимо получить из БД, в противном случае значения реквизитов хранятся в памяти.

ЭтоСсылка = ЭтоСсылка ( Объект );
СсылкаОбъекта = ?( ЭтоСсылка , Объект , Объект . Ссылка );

ПолучитьДанныеИзОбъекта = НЕ ЭтоСсылка ;
Если ЭтоСсылка И СсылкаОбъекта . Пустая () тогда
// это пустая ссылка (данных в базе нет)
ПолучитьДанныеИзОбъекта = Истина;
КонецЕсли;

Теперь, если данные объекта хранятся в памяти – мы можем их сразу получить, в противном случае необходио подготовиться для составления запроса к БД (переведем список имен реквизитов из типа данных Массив в тип Структура).

ОсновныеРеквизиты = Новый Структура ;
Для каждого ИмяРеквизита Из МассивИменРеквизитов Цикл
Если ПолучитьДанныеИзОбъекта тогда
СтруктураОбъекта . Вставить ( ИмяРеквизита , Объект [ ИмяРеквизита ]);
иначе
ОсновныеРеквизиты . Вставить ( ИмяРеквизита );
КонецЕсли;
КонецЦикла;

Все готово к составлению запроса чтобы получить значения реквизитов если перед нами объект ссылочного типа, а так же для получения дополнительных реквизитов, описанных в 3-ем параметре функции. Но смысл всех этих действий есть, только если данный объект существует в БД (на него есть ссылка).

Для начала составим текст запроса для полей выборки поочередно обходя структуры Основных и Дополнительных реквизитов

Если НЕ СсылкаОбъекта . Пустая () тогда

// сформируем текст выборки по реквизитам
ТекстВыборкиРеквизиты = “” ;
Для индекс = 0 по 1 Цикл
СтруктураРеквизитов = ?( индекс = 0 , ОсновныеРеквизиты , ДополнительныеРеквизиты );
Если СтруктураРеквизитов = Неопределено тогда
Продолжить;
КонецЕсли;
Для каждого ЭлементСтруктуры из СтруктураРеквизитов Цикл
Если НЕ МетаданныеОбъекта . ТабличныеЧасти . Найти ( ЭлементСтруктуры . Ключ ) = Неопределено тогда
// это имя табличной части
Продолжить;
КонецЕсли;
ТекстВыборкиРеквизиты = ТекстВыборкиРеквизиты
+ ?( ПустаяСтрока ( ТекстВыборкиРеквизиты ), “” , “,” + Символы . ПС )
+ ?( ЗначениеЗаполнено ( ЭлементСтруктуры . Значение ), ЭлементСтруктуры . Значение , ЭлементСтруктуры . Ключ )
+ ” КАК ” + ЭлементСтруктуры . Ключ ;
КонецЦикла;
КонецЦикла;

Теперь соберем текст запроса и выполним его. Результат запроса добавим в общую структуру данных объекта

// получим реквизиты одним запросом
Если НЕ ПустаяСтрока ( ТекстВыборкиРеквизиты ) тогда
Запрос = Новый Запрос ;
Запрос . Текст = “ВЫБРАТЬ
|” + ТекстВыборкиРеквизиты + ”
|ИЗ
| ” + МетаданныеОбъекта . ПолноеИмя () + ”
|ГДЕ
| Ссылка = &Ссылка” ;
Запрос . УстановитьПараметр ( “Ссылка” , СсылкаОбъекта );
РезультатЗапроса = Запрос . Выполнить ();
Выборка = РезультатЗапроса . Выбрать ();
Если Выборка . Следующий () тогда
Для каждого Колонка из РезультатЗапроса . Колонки Цикл
СтруктураОбъекта . Вставить ( Колонка . Имя , Выборка [ Колонка . Имя ]);
КонецЦикла;
КонецЕсли;
КонецЕсли;

Все данные получены, можно завершать функцию

Достоинства алгоритма:

  1. Может работать с различными типами объектов конфигурации (которые могут иметь ссылки: Справочники, Документы, ПВХ и т.п.);
  2. Получение всех реквизитов за одно обращение к БД;
  3. Данные возвращаются в виде структуры, что позволяет их передать далее на клиент без преобразования;
  4. С помошью Дополнительных реквизитов можно получить вспомогательные данные (обращение к полям выборки через несколько точек) или на уровне запроса выполнить какие-то действия с данными.
  5. Наглядность кода, данные получаются одной функцией, без надобности каждый раз писать запрос к БД с обработкой результата.

Недостатки:

  1. Не реализована возможность получения табличных частей объектов

Дополнительные функции использованные в алгоритме:

// Возвращает массив имен всех реквизитов переданного объекта
//
Функция МассивИменРеквизитовОбъекта ( Объект ) Экспорт

МассивИменРеквизитов = Новый Массив ;

Если ТипЗнч ( Объект ) = Тип ( “ОбъектМетаданных” ) тогда
МетаданныеОбъекта = Объект ;
иначе
МетаданныеОбъекта = Метаданные . НайтиПоТипу ( ТипЗнч ( Объект ));
Если МетаданныеОбъекта = Неопределено тогда
Возврат МассивИменРеквизитов ;
КонецЕсли;
КонецЕсли;

Для индекс = 0 по 1 Цикл
КоллекцияРеквизитов = ?( индекс = 0 , МетаданныеОбъекта . СтандартныеРеквизиты , МетаданныеОбъекта . Реквизиты );
Для Каждого Реквизит Из КоллекцияРеквизитов Цикл
МассивИменРеквизитов . Добавить ( Реквизит . Имя );
КонецЦикла;
КонецЦикла;
Для каждого ОбщийРеквизит Из Метаданные . ОбщиеРеквизиты Цикл
Если ИспользуетсяОбщийРеквизит ( ОбщийРеквизит , МетаданныеОбъекта ) тогда
МассивИменРеквизитов . Добавить ( ОбщийРеквизит . Имя );
КонецЕсли;
КонецЦикла;

// Проверяет используется ли в Объекте указанный общий реквизит
//
Функция ИспользуетсяОбщийРеквизит ( ОбщийРеквизит , Объект ) Экспорт

Если ТипЗнч ( Объект ) = Тип ( “ОбъектМетаданных” ) тогда
МетаданныеОбъекта = Объект ;
иначе
МетаданныеОбъекта = Метаданные . НайтиПоТипу ( ТипЗнч ( Объект ));
Если МетаданныеОбъекта = Неопределено тогда
Возврат Ложь;
КонецЕсли;
КонецЕсли;

Если ТипЗнч ( ОбщийРеквизит ) = Тип ( “ОбъектМетаданных” ) тогда
МетаданныеОбщегоРеквизита = ОбщийРеквизит ;
иначе
МетаданныеОбщегоРеквизита = Метаданные . ОбщиеРеквизиты . Найти ( ОбщийРеквизит );
Если МетаданныеОбщегоРеквизита = Неопределено тогда
Возврат Ложь;
КонецЕсли;
КонецЕсли;

ЭлементСостава = МетаданныеОбщегоРеквизита . Состав . Найти ( МетаданныеОбъекта );
Если ЭлементСостава = Неопределено тогда
Возврат Ложь;
КонецЕсли;

пИспользованиеОбщегоРеквизита = Метаданные . СвойстваОбъектов . ИспользованиеОбщегоРеквизита ;
Если ЭлементСостава . Использование = пИспользованиеОбщегоРеквизита . Использовать тогда
Возврат Истина;
иначеЕсли ЭлементСостава . Использование = пИспользованиеОбщегоРеквизита . НеИспользовать тогда
Возврат Ложь;
иначе
пАвтоИспользованиеОбщегоРеквизита = Метаданные . СвойстваОбъектов . АвтоИспользованиеОбщегоРеквизита ;
Если МетаданныеОбщегоРеквизита . АвтоИспользование = пАвтоИспользованиеОбщегоРеквизита . Использовать тогда
Возврат Истина;
иначе
Возврат Ложь;
КонецЕсли;
КонецЕсли;

Ссылка на основную публикацию
Adblock
detector